BBR for Debian/Ubuntu x64 KVM

如安装有逗比 SSR, 可直接在管理脚本选择14 安装BBR.

系统要求:Debian 7+ / Ubuntu 14.04+ 均x64位。
TCP拥塞控制技术Google BBR 安装脚本:

1
wget -N --no-check-certificate https://raw.githubusercontent.com/ToyoDAdoubi/doubi/master/bbr.sh && chmod +x bbr.sh && bash bbr.sh

下载并运行脚本后,会自动检测并开始安装,首先会提示你输入要下载的内核版本,直接回车则安装最新版本的内核。目前该BBR脚本版本Ver 1.0.22 支持最高的Linux 内核版本是4.16.3. 建议输入该版本号。

附Linux 内核版本列表:http://kernel.ubuntu.com/~kernel-ppa/mainline/

如果Xshell出现:闪现,按q;卡死 按Ctrl+c 再试。

注意:在Debian系统中,删除旧内核时,会提示你是否终止删除内核的行为,这个需要你选择No。

如果没有出错,内核更换完毕后,会提示重启VPS。回车重启。

重启后执行 bash bbr.sh status 查看BBR是否加载成功,lsmod | grep bbr 确认,YouTube 测试加速效果。

查看BBR状态: bash bbr.sh status
升级BBR: bash bbr.sh #重新执行脚本,检测最新内核和当前内核,对比版本。
启动BBR: bash bbr.sh start
关闭BBR: bash bbr.sh stop
注意:关闭BBR,需要重启VPS,所以脚本会提醒是否立即重启VPS。

详情参考 https://doub.io/wlzy-16/

Leave a Reply

Your email address will not be published.